Watch is not keeping correct time.

DonaldJAlschulerDonaldJAlschuler Posts: 9Member
edited September 2013 in Support
My watch is running very fast and does not keep correct time.
Post edited by whacko on


  • I am using Pebble connected to my iPhone 4S IOS 6.1.3. I have set the Pebble manually. It is connected to the phone when the phone is near. But I don't carry my phone all the time. I expect the watch to keep the current time.This is a new phone. Just installed and the fast seems to have begun from the first day. I have had to reset repeatedly. I have not tried a factory reset.I have reset the time now. Will test again. Thanks for your comments
  • I must have a defective Pebble. At 6:25PM Pacifc time I set the Pebble to 6:25PM
    At 9:26PM on the iPhone the Pebble says the time is 9:45PM. Both the Pebble and the iPhone say they are connected. They have been side by side since 6:25PM.
    As far as I know I am running the latest watch firmware. It is new out of the box on Monday.
    Bottom line. I guess I should just return the watch.
    Thanks for you attempt to help me.

  • Firmware is v1.10.1    Recovery is v1.5.4  boot loader0x51677d8f
    Time on iPhone 7:58AM Time on 9:22AM
    Per your prior message the latest firmware is 1.12.1
    I will attempt to install the this firmware and report the results. This correspondence is serving as a record.
    Thanks again for your help.

  • SandbagSandbag Posts: 232Member Regular
    This correspondence is serving as a record.
    Thanks again for your help.

    This forum is not where you would want to save a correspondence for a record. This is just a user forum and not the official place to report problems. That's done from within the Pebble app on your iPhone.

    iPhone 5s 64gb, iOS 8.1, jailbroken
  • OK. Thanks.
  • i upgraded the firmware and the watch appears to be keeping the correct time. 
  • JarleLindsethJarleLindseth Posts: 2Member
    I'm gonna chime in here and say that my pwbble is not keeping time correctly either. It's losing about time very rapidly. I'd say it's running about 5% too slow.
    I just got my phone and still haven't gotten around to chosing an adroid yet since I'm using WP8 atm. No phone => no firmware update. (currently v1.10.0) So I'm guessing that's where the problem is.

    However: I must say I am disappointed that a watch is not able to keep time. I would imagine that a primary reason for waring a watch is to be able to tell time, even if this watch is very fancy and can do heaps of other stuff. Does the pebble not have a proper time-telling-hardware at its core?
  • I upgraded the firmware and that solved a similar issue.

Sign In or Register to comment.